What’s Vulnerable › Vulnerabilities
CVE-2024-35728: WordPress Product Addons & Fields for WooCommerce plugin <= 32.0.20 - Content Injection vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-10 · updated 2026-06-17
- Weakness: CWE-74
Description
Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in Themeisle PPOM for WooCommerce allows Code Inclusion.This issue affects PPOM for WooCommerce: from n/a through 32.0.20.
Affected products
- themeisle PPOM – Product Addons & Custom Fields for WooCommerce: before 32.0.21 — fixed in 32.0.21
How to fix
Upgrade to a fixed version: themeisle PPOM – Product Addons & Custom Fields for WooCommerce 32.0.21. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woocommerce-product-addon/wordpress-product-addons-fields-for-woocommerce-plugin-32-0-20-content-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woocommerce-product-addon/wordpress-product-addons-fields-for-woocommerce-plugin-32-0-20-content-injection-vulnerability?_s_id=cve
Get alerted when CVE-2024-35728 or the next vulnerability affects your stack