What’s Vulnerable › Vulnerabilities
CVE-2024-35731: WordPress Kenta Gutenberg Blocks plugin <= 1.3.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WP Moose Kenta Gutenberg Blocks Responsive Blocks and block templates library for Gutenberg Editor allows Stored XSS.This issue affects Kenta Gutenberg Blocks Responsive Blocks and block templates library for Gutenberg Editor: from n/a through 1.3.9.
Affected products
- WP Moose Kenta Gutenberg Blocks Responsive Blocks and block templates library for Gutenberg Editor: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: WP Moose Kenta Gutenberg Blocks Responsive Blocks and block templates library for Gutenberg Editor 1.4.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/kenta-blocks/wordpress-kenta-gutenberg-blocks-plugin-1-3-9-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/kenta-blocks/wordpress-kenta-gutenberg-blocks-plugin-1-3-9-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35731 or the next vulnerability affects your stack