What’s Vulnerable › Vulnerabilities
CVE-2024-35733: WordPress Auto Coupons for WooCommerce plugin <= 3.0.14 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in RLDD Auto Coupons for WooCommerce allows Reflected XSS.This issue affects Auto Coupons for WooCommerce: from n/a through 3.0.14.
Affected products
- RLDD Auto Coupons for WooCommerce: before 3.0.15 — fixed in 3.0.15
How to fix
Upgrade to a fixed version: RLDD Auto Coupons for WooCommerce 3.0.15. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woo-auto-coupons/wordpress-auto-coupons-for-woocommerce-plugin-3-0-14-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woo-auto-coupons/wordpress-auto-coupons-for-woocommerce-plugin-3-0-14-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35733 or the next vulnerability affects your stack