What’s Vulnerable › Vulnerabilities
CVE-2024-35738: WordPress Kognetiks Chatbot for WordPress plugin <= 1.9.8 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Kognetiks Kognetiks Chatbot for WordPress allows Stored XSS.This issue affects Kognetiks Chatbot for WordPress: from n/a through 1.9.8.
Affected products
- Kognetics Kognetiks Chatbot: before 1.9.9 — fixed in 1.9.9
How to fix
Upgrade to a fixed version: Kognetics Kognetiks Chatbot 1.9.9. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/chatbot-chatgpt/wordpress-kognetiks-chatbot-for-wordpress-plugin-1-9-8-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/chatbot-chatgpt/wordpress-kognetiks-chatbot-for-wordpress-plugin-1-9-8-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35738 or the next vulnerability affects your stack