What’s Vulnerable › Vulnerabilities
CVE-2024-35751: WordPress Woody code snippets plugin <= 2.4.10 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Creative Motion, Will Bontrager Software, LLC Woody ad snippets allows Stored XSS.This issue affects Woody ad snippets: from n/a through 2.4.10.
Affected products
- themeisle Woody Code Snippets – Insert PHP, CSS, JS, and Header/Footer Scripts: before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: themeisle Woody Code Snippets – Insert PHP, CSS, JS, and Header/Footer Scripts 2.5.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/insert-php/wordpress-woody-code-snippets-plugin-2-4-10-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/insert-php/wordpress-woody-code-snippets-plugin-2-4-10-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35751 or the next vulnerability affects your stack