What’s Vulnerable › Vulnerabilities
CVE-2024-35755: WordPress Weather Widget Pro plugin <= 1.1.40 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in El tiempo Weather Widget Pro allows Stored XSS.This issue affects Weather Widget Pro: from n/a through 1.1.40.
Affected products
- El tiempo Weather Widget Pro: before 1.1.41 — fixed in 1.1.41
How to fix
Upgrade to a fixed version: El tiempo Weather Widget Pro 1.1.41. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/weather-in-any-city-widget/wordpress-weather-widget-pro-plugin-1-1-40-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/weather-in-any-city-widget/wordpress-weather-widget-pro-plugin-1-1-40-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35755 or the next vulnerability affects your stack