What’s Vulnerable › Vulnerabilities
CVE-2024-35758: WordPress Interface theme <= 3.1.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Theme Horse Interface allows Stored XSS.This issue affects Interface: from n/a through 3.1.0.
Affected products
- Theme Horse Interface: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Theme Horse Interface 3.1.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/interface/wordpress-interface-theme-3-1-0-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/interface/wordpress-interface-theme-3-1-0-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35758 or the next vulnerability affects your stack