What’s Vulnerable › Vulnerabilities
CVE-2024-35760: WordPress WP Job Portal plugin <= 2.1.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpjobportal WP Job Portal wp-job-portal allows DOM-Based XSS.This issue affects WP Job Portal: from n/a through <= 2.1.3.
Affected products
- wpjobportal WP Job Portal – AI-Powered Recruitment System for Company or Job Board website: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: wpjobportal WP Job Portal – AI-Powered Recruitment System for Company or Job Board website 2.1.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/wp-job-portal/vulnerability/wordpress-wp-job-portal-a-complete-job-board-plugin-2-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-job-portal/wordpress-wp-job-portal-a-complete-job-board-plugin-2-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35760 or the next vulnerability affects your stack