What’s Vulnerable › Vulnerabilities
CVE-2024-35792: crypto: rk3288 - Fix use after free in unprepare
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: rk3288 - Fix use after free in unprepare The unprepare call must be carried out before the finalize call as the latter can free the request.
Affected products
- Linux kernel: from 6.6 before 6.6.24; from 6.7 before 6.7.12; 6.8-rc1, 6.8-rc2, 6.8-rc3, 6.8-rc4, 6.8-rc5, 6.8-rc6 — fixed in 6.6.24, 6.7.12
How to fix
Upgrade to a fixed version: Linux kernel 6.6.24, 6.7.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/48dd260fdb728eda4a246f635d1325e82f0d3555
- https://git.kernel.org/stable/c/c0afb6b88fbbc177fa322a835f874be217bffe45
- https://git.kernel.org/stable/c/eb2a41a8ae8c8c4f68aef3bd94665c0cf23e04be
- https://git.kernel.org/stable/c/48dd260fdb728eda4a246f635d1325e82f0d3555
- https://git.kernel.org/stable/c/c0afb6b88fbbc177fa322a835f874be217bffe45
- https://git.kernel.org/stable/c/eb2a41a8ae8c8c4f68aef3bd94665c0cf23e04be
Get alerted when CVE-2024-35792 or the next vulnerability affects your stack