What’s Vulnerable › Vulnerabilities
CVE-2024-35806: soc: fsl: qbman: Always disable interrupts when taking cgr_lock
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: soc: fsl: qbman: Always disable interrupts when taking cgr_lock smp_call_function_single disables IRQs when executing the callback. To prevent deadlocks, we must disable IRQs when taking cgr_lock elsewhere. This is already done by qman_update_cgr and qman_delete_cgr; fix the other lockers.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 4.9.92 before 4.10; from 4.14.32 before 4.15; from 4.15.15 before 4.19.312; from 4.20 before 5.4.274; from 5.5 before 5.10.215; from 5.11 before 5.15.154 — fixed in 4.10, 4.15, 4.19.312, 5.10.215, 5.15.154, 5.4.274
How to fix
Upgrade to a fixed version: Linux kernel 4.10, 4.15, 4.19.312, 5.10.215. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0e6521b0f93ff350434ed4ae61a250907e65d397
- https://git.kernel.org/stable/c/276af8efb05c8e47acf2738a5609dd72acfc703f
- https://git.kernel.org/stable/c/584c2a9184a33a40fceee838f856de3cffa19be3
- https://git.kernel.org/stable/c/62c3ecd2833cff0eff4a82af4082c44ca8d2518a
- https://git.kernel.org/stable/c/a62168653774c36398d65846a98034436ee66d03
- https://git.kernel.org/stable/c/af25c5180b2b1796342798f6c56fcfd12f5035bd
- https://git.kernel.org/stable/c/b56a793f267679945d1fdb9a280013bd2d0ed7f9
- https://git.kernel.org/stable/c/dd199e5b759ffe349622a4b8fbcafc51fc51b1ec
- https://git.kernel.org/stable/c/e6378314bb920acb39013051fa65d8f9f8030430
- https://git.kernel.org/stable/c/0e6521b0f93ff350434ed4ae61a250907e65d397
- https://git.kernel.org/stable/c/276af8efb05c8e47acf2738a5609dd72acfc703f
- https://git.kernel.org/stable/c/584c2a9184a33a40fceee838f856de3cffa19be3
Get alerted when CVE-2024-35806 or the next vulnerability affects your stack