What’s Vulnerable › Vulnerabilities
CVE-2024-3584: Path Traversal in qdrant/qdrant
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-30 · updated 2026-06-17
- Weakness: CWE-20
Description
qdrant/qdrant version 1.9.0-dev is vulnerable to path traversal due to improper input validation in the `/collections/{name}/snapshots/upload` endpoint. By manipulating the `name` parameter through URL encoding, an attacker can upload a file to an arbitrary location on the system, such as `/root/poc.txt`. This vulnerability allows for the writing and overwriting of arbitrary files on the server, potentially leading to a full takeover of the system. The issue is fixed in version 1.9.0.
Affected products
- qdrant/qdrant: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: qdrant/qdrant 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/qdrant/qdrant/commit/15479a45ffa3b955485ae516696f7e933a8cce8a
- https://huntr.com/bounties/5c7c82e2-4873-40b7-a5f3-0f4a42642f73
- https://github.com/qdrant/qdrant/commit/15479a45ffa3b955485ae516696f7e933a8cce8a
- https://huntr.com/bounties/5c7c82e2-4873-40b7-a5f3-0f4a42642f73
Get alerted when CVE-2024-3584 or the next vulnerability affects your stack