What’s Vulnerable › Vulnerabilities
CVE-2024-35924: usb: typec: ucsi: Limit read size on v1.2
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-19 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: usb: typec: ucsi: Limit read size on v1.2 Between UCSI 1.2 and UCSI 2.0, the size of the MESSAGE_IN region was increased from 16 to 256. In order to avoid overflowing reads for older systems, add a mechanism to use the read UCSI version to truncate read sizes on UCSI v1.2.
Affected products
- Linux kernel: from 5.5 before 6.6.27; from 6.7 before 6.8.6 — fixed in 6.6.27, 6.8.6
- Linux: 5.5 — fixed in 6.9
How to fix
Upgrade to a fixed version: Linux kernel 6.6.27, 6.8.6; Linux 6.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0defcaa09d3b21e8387829ee3a652c43fa91e13f
- https://git.kernel.org/stable/c/266f403ec47573046dee4bcebda82777ce702c40
- https://git.kernel.org/stable/c/af9bdf05557dc21040df2f11062133dd1e503a09
- https://git.kernel.org/stable/c/b3db266fb031fba88c423d4bb8983a73a3db6527
- https://git.kernel.org/stable/c/0defcaa09d3b21e8387829ee3a652c43fa91e13f
- https://git.kernel.org/stable/c/266f403ec47573046dee4bcebda82777ce702c40
- https://git.kernel.org/stable/c/b3db266fb031fba88c423d4bb8983a73a3db6527
Get alerted when CVE-2024-35924 or the next vulnerability affects your stack