What’s Vulnerable › Vulnerabilities
CVE-2024-3593: UberMenu <= 3.8.3 - Cross-Site Request Forgery to Settings Reset
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The UberMenu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.8.3. This is due to missing or incorrect nonce validation on the ubermenu_delete_all_item_settings and ubermenu_reset_settings functions. This makes it possible for unauthenticated attackers to delete and reset the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- SevenSpark UberMenu: before 3.8.4 — fixed in 3.8.4
How to fix
Upgrade to a fixed version: SevenSpark UberMenu 3.8.4. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/ubermenu-wordpress-mega-menu-plugin/154703
- https://www.wordfence.com/threat-intel/vulnerabilities/id/621ef583-bf99-4b81-ae9c-b4f1c86b86aa?source=cve
- https://codecanyon.net/item/ubermenu-wordpress-mega-menu-plugin/154703
- https://www.wordfence.com/threat-intel/vulnerabilities/id/621ef583-bf99-4b81-ae9c-b4f1c86b86aa?source=cve
Get alerted when CVE-2024-3593 or the next vulnerability affects your stack