What’s Vulnerable › Vulnerabilities
CVE-2024-35963: Bluetooth: hci_sock: Fix not validating setsockopt user input
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-20 · updated 2026-08-04
- Weakness: CWE-1284
Description
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: hci_sock: Fix not validating setsockopt user input Check user input length before copying data.
Affected products
- Linux kernel: from 5.16 before 6.1.113; from 6.2 before 6.6.55; from 6.7 before 6.8.7; 6.9-rc1, 6.9-rc2, 6.9-rc3 — fixed in 6.1.113, 6.6.55, 6.8.7
How to fix
Upgrade to a fixed version: Linux kernel 6.1.113, 6.6.55, 6.8.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0c18a64039aa3f1c16f208d197c65076da798137
- https://git.kernel.org/stable/c/50173882bb187e70e37bac01385b9b114019bee2
- https://git.kernel.org/stable/c/781f3a97a38a338bc893b6db7f9f9670bf1a9e37
- https://git.kernel.org/stable/c/b2186061d6043d6345a97100460363e990af0d46
- https://git.kernel.org/stable/c/50173882bb187e70e37bac01385b9b114019bee2
- https://git.kernel.org/stable/c/b2186061d6043d6345a97100460363e990af0d46
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-35963 or the next vulnerability affects your stack