What’s Vulnerable › Vulnerabilities
CVE-2024-35964: Bluetooth: ISO: Fix not validating setsockopt user input
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-20 · updated 2026-06-17
- Weakness: CWE-1284
Description
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: ISO: Fix not validating setsockopt user input Check user input length before copying data.
Affected products
- Linux kernel: from 6.0 before 6.1.119; from 6.2 before 6.6.55; from 6.7 before 6.8.7; 6.9-rc1, 6.9-rc2, 6.9-rc3 — fixed in 6.1.119, 6.6.55, 6.8.7
How to fix
Upgrade to a fixed version: Linux kernel 6.1.119, 6.6.55, 6.8.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0c4a89f4690478969729c7ba5f69d53d8516aa12
- https://git.kernel.org/stable/c/6a6baa1ee7a9df33adbf932305053520b9741b35
- https://git.kernel.org/stable/c/9e8742cdfc4b0e65266bb4a901a19462bda9285e
- https://git.kernel.org/stable/c/cec736e60dc18d91b88af28d96664bff284b02d1
- https://git.kernel.org/stable/c/0c4a89f4690478969729c7ba5f69d53d8516aa12
- https://git.kernel.org/stable/c/9e8742cdfc4b0e65266bb4a901a19462bda9285e
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-35964 or the next vulnerability affects your stack