What’s Vulnerable › Vulnerabilities
CVE-2024-35983: bounds: Use the right number of bits for power-of-two CONFIG_NR_CPUS
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-20 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: bounds: Use the right number of bits for power-of-two CONFIG_NR_CPUS bits_per() rounds up to the next power of two when passed a power of two. This causes crashes on some machines and configurations.
Affected products
- Linux kernel: from 5.4.274 before 5.4.275; from 5.10.215 before 5.10.216; from 5.15.154 before 5.15.158; from 6.1.84 before 6.1.90; from 6.6.24 before 6.6.30; from 6.7.12 before 6.8 — fixed in 5.10.216, 5.15.158, 5.4.275, 6.1.90, 6.6.30, 6.8
How to fix
Upgrade to a fixed version: Linux kernel 5.10.216, 5.15.158, 5.4.275, 6.1.90. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/15aa09d6d84629eb5296de30ac0aa19a33512f16
- https://git.kernel.org/stable/c/5af385f5f4cddf908f663974847a4083b2ff2c79
- https://git.kernel.org/stable/c/66297b2ceda841f809637731d287bda3a93b49d8
- https://git.kernel.org/stable/c/93ba36238db6a74a82feb3dc476e25ea424ad630
- https://git.kernel.org/stable/c/9b7c5004d7c5ae062134052a85290869a015814c
- https://git.kernel.org/stable/c/d34a516f2635090d36a306f84573e8de3d7374ce
- https://git.kernel.org/stable/c/ebfe41889b762f1933c6762f6624b9724a25bee0
- https://git.kernel.org/stable/c/15aa09d6d84629eb5296de30ac0aa19a33512f16
- https://git.kernel.org/stable/c/5af385f5f4cddf908f663974847a4083b2ff2c79
- https://git.kernel.org/stable/c/66297b2ceda841f809637731d287bda3a93b49d8
- https://git.kernel.org/stable/c/93ba36238db6a74a82feb3dc476e25ea424ad630
- https://git.kernel.org/stable/c/9b7c5004d7c5ae062134052a85290869a015814c
Get alerted when CVE-2024-35983 or the next vulnerability affects your stack