What’s Vulnerable › Vulnerabilities
CVE-2024-36014: drm/arm/malidp: fix a possible null pointer dereference
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-29 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: drm/arm/malidp: fix a possible null pointer dereference In malidp_mw_connector_reset, new memory is allocated with kzalloc, but no check is performed. In order to prevent null pointer dereferencing, ensure that mw_state is checked before calling __drm_atomic_helper_connector_reset.
Affected products
- Linux kernel: from 4.19 before 4.19.316; from 4.20 before 5.4.278; from 5.5 before 5.10.219; from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33 — fixed in 4.19.316, 5.10.219, 5.15.161, 5.4.278, 6.1.93, 6.6.33
How to fix
Upgrade to a fixed version: Linux kernel 4.19.316, 5.10.219, 5.15.161, 5.4.278. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/335cc45ef2b81b68be63c698b4f867a530bdf7a5
- https://git.kernel.org/stable/c/3e54d4e95120641216dfe91a6c49f116a9f68490
- https://git.kernel.org/stable/c/565d9ad7e5a18eb69ed8b66a9e9bb3f45346520c
- https://git.kernel.org/stable/c/93f76ec1eddce60dbb5885cbc0d7df54adee4639
- https://git.kernel.org/stable/c/a1f95aede6285dba6dd036d907196f35ae3a11ea
- https://git.kernel.org/stable/c/a5fa5b40a278a3ca978fed64707bd27614adb1eb
- https://git.kernel.org/stable/c/b6cc5dd06336ed8bb3a7a1fc5aaf7d5e88bc0818
- https://git.kernel.org/stable/c/b77620730f614059db2470e8ebab3e725280fc6d
- https://git.kernel.org/stable/c/e4b52d49383306ef73fd1bd9102538beebb0fe07
- https://git.kernel.org/stable/c/335cc45ef2b81b68be63c698b4f867a530bdf7a5
- https://git.kernel.org/stable/c/3e54d4e95120641216dfe91a6c49f116a9f68490
- https://git.kernel.org/stable/c/565d9ad7e5a18eb69ed8b66a9e9bb3f45346520c
Get alerted when CVE-2024-36014 or the next vulnerability affects your stack