What’s Vulnerable › Vulnerabilities
CVE-2024-36025: scsi: qla2xxx: Fix off by one in qla_edif_app_getstats()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-06-17
- Weakness: CWE-193
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: qla2xxx: Fix off by one in qla_edif_app_getstats() The app_reply->elem[] array is allocated earlier in this function and it has app_req.num_ports elements. Thus this > comparison needs to be >= to prevent memory corruption.
Affected products
- Linux kernel: from 5.15 before 5.15.156; from 5.16 before 6.1.87; from 6.2 before 6.6.28; from 6.7 before 6.8.7; 6.9-rc1, 6.9-rc2, 6.9-rc3 — fixed in 5.15.156, 6.1.87, 6.6.28, 6.8.7
How to fix
Upgrade to a fixed version: Linux kernel 5.15.156, 6.1.87, 6.6.28, 6.8.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4406e4176f47177f5e51b4cc7e6a7a2ff3dbfbbd
- https://git.kernel.org/stable/c/60b87b5ecbe07d70897d35947b0bb3e76ccd1b3a
- https://git.kernel.org/stable/c/8c820f7c8e9b46238d277c575392fe9930207aab
- https://git.kernel.org/stable/c/9fc74e367be4247a5ac39bb8ec41eaa73fade510
- https://git.kernel.org/stable/c/ea8ac95c22c93acecb710209a7fd10b851afe817
- https://git.kernel.org/stable/c/4406e4176f47177f5e51b4cc7e6a7a2ff3dbfbbd
- https://git.kernel.org/stable/c/60b87b5ecbe07d70897d35947b0bb3e76ccd1b3a
- https://git.kernel.org/stable/c/8c820f7c8e9b46238d277c575392fe9930207aab
- https://git.kernel.org/stable/c/9fc74e367be4247a5ac39bb8ec41eaa73fade510
- https://git.kernel.org/stable/c/ea8ac95c22c93acecb710209a7fd10b851afe817
Get alerted when CVE-2024-36025 or the next vulnerability affects your stack