What’s Vulnerable › Vulnerabilities

CVE-2024-36048

Description

QAbstractOAuth in Qt Network Authorization in Qt before 5.15.17, 6.x before 6.2.13, 6.3.x through 6.5.x before 6.5.6, and 6.6.x through 6.7.x before 6.7.1 uses only the time to seed the PRNG, which may result in guessable values.

Affected products

How to fix

Upgrade to a fixed version: Qt 5.15.17, 6.2.13, 6.5.6, 6.7.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-36048 or the next vulnerability affects your stack