What’s Vulnerable › Vulnerabilities
CVE-2024-36108: Multiple Broken Function-Level Authorization vulnerabilities in casgate
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-285
Description
casgate is an Open Source Identity and Access Management system. In affected versions `casgate` allows remote unauthenticated attacker to obtain sensitive information via GET request to an API endpoint. This issue has been addressed in PR #201 which is pending merge. An attacker could use `id` parameter of GET requests with value `anonymous/ anonymous` to bypass authorization on certain API endpoints. Successful exploitation of the vulnerability could lead to account takeover, privilege escalation or provide attacker with credential to other services. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- casgate: before 0.1.0 — fixed in 0.1.0
How to fix
Upgrade to a fixed version: casgate 0.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/casgate/casgate/pull/201
- https://github.com/casgate/casgate/security/advisories/GHSA-mj5q-rc67-h56c
- https://github.com/casgate/casgate/pull/201
- https://github.com/casgate/casgate/security/advisories/GHSA-mj5q-rc67-h56c
Get alerted when CVE-2024-36108 or the next vulnerability affects your stack