What’s Vulnerable › Vulnerabilities
CVE-2024-36110: Cross-site scripting in ansibleguy-webui
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-28 · updated 2026-06-17
- Weakness: CWE-79
Description
ansibleguy-webui is an open source WebUI for using Ansible. Multiple forms in versions < 0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser. These issues have been addressed in version 0.0.21 (0.0.21.post2 on pypi). Users are advised to upgrade. There are no known workarounds for these issues.
Affected products
- ansibleguy webui: before 0.0.21 — fixed in 0.0.21
How to fix
Upgrade to a fixed version: ansibleguy webui 0.0.21. Check the vendor advisory for mitigations.
References
- https://github.com/ansibleguy/webui/commit/7737b47e7f7ddbfec7b1418c724598363718d522
- https://github.com/ansibleguy/webui/files/15358522/Report.pdf
- https://github.com/ansibleguy/webui/issues/44
- https://github.com/ansibleguy/webui/security/advisories/GHSA-927p-xrc2-x2gj
- https://github.com/ansibleguy/webui/commit/7737b47e7f7ddbfec7b1418c724598363718d522
- https://github.com/ansibleguy/webui/files/15358522/Report.pdf
- https://github.com/ansibleguy/webui/issues/44
- https://github.com/ansibleguy/webui/security/advisories/GHSA-927p-xrc2-x2gj
Get alerted when CVE-2024-36110 or the next vulnerability affects your stack