What’s Vulnerable › Vulnerabilities
CVE-2024-36113: Discourse missing authorization checks for suspending admins/moderators
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch, a rogue staff user could suspend other staff users preventing them from logging in to the site. The issue is patched in version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch. No known workarounds are available.
Affected products
- discourse: before 3.2.3; before 3.3.0; 3.3.0-beta1, 3.3.0-beta2 — fixed in 3.2.3, 3.3.0
How to fix
Upgrade to a fixed version: discourse 3.2.3, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/8470546f59b04bd82ce9b711406758fd5439936d
- https://github.com/discourse/discourse/commit/9c4a5f39d3ad351410a1453ff5e5f7ffce17cd7e
- https://github.com/discourse/discourse/security/advisories/GHSA-3w3f-76p7-3c4g
- https://github.com/discourse/discourse/commit/8470546f59b04bd82ce9b711406758fd5439936d
- https://github.com/discourse/discourse/commit/9c4a5f39d3ad351410a1453ff5e5f7ffce17cd7e
- https://github.com/discourse/discourse/security/advisories/GHSA-3w3f-76p7-3c4g
Get alerted when CVE-2024-36113 or the next vulnerability affects your stack