What’s Vulnerable › Vulnerabilities
CVE-2024-36120: javascript-deobfuscator crafted payload can lead to code execution
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-94
Description
javascript-deobfuscator removes common JavaScript obfuscation techniques. In affected versions crafted payloads targeting expression simplification can lead to code execution. This issue has been patched in version 1.1.0. Users are advised to update. Users unable to upgrade should disable the expression simplification feature.
Affected products
- ben-sb javascript-deobfuscator: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: ben-sb javascript-deobfuscator 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/ben-sb/javascript-deobfuscator/commit/630d3caec83d5f31c5f7a07e6fadf613d06699d6
- https://github.com/ben-sb/javascript-deobfuscator/security/advisories/GHSA-9p6p-8v9r-8c9m
- https://github.com/ben-sb/javascript-deobfuscator/commit/630d3caec83d5f31c5f7a07e6fadf613d06699d6
- https://github.com/ben-sb/javascript-deobfuscator/security/advisories/GHSA-9p6p-8v9r-8c9m
Get alerted when CVE-2024-36120 or the next vulnerability affects your stack