What’s Vulnerable › Vulnerabilities
CVE-2024-36244: net/sched: taprio: extend minimum interval restriction to entire cycle too
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-21 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: net/sched: taprio: extend minimum interval restriction to entire cycle too It is possible for syzbot to side-step the restriction imposed by the blamed commit in the Fixes: tag, because the taprio UAPI permits a cycle-time different from (and potentially shorter than) the sum of entry intervals. We need one more restriction, which is that the cycle time itself must be larger than N * ETH_ZLEN bit times, where N is the number of schedule entries. This restriction needs to apply regardless of whether the cycle time came from the user or was the implicit, auto-calculated value, so we move the existing "cycle == 0" check outside the "if "(!new->cycle_time)" branch. This way covers both conditions and scenarios. Add a selftest which illustrates the issue triggered by syzbot.
Affected products
- Linux kernel: from 5.4.68 before 5.5; from 5.8.12 before 5.9; from 5.9.1 before 6.1.119; from 6.2 before 6.6.33; from 6.7 before 6.9.4; 5.9, 5.9-rc7, 5.9-rc8, 6.10-rc1 — fixed in 5.5, 5.9, 6.1.119, 6.6.33, 6.9.4
How to fix
Upgrade to a fixed version: Linux kernel 5.5, 5.9, 6.1.119, 6.6.33. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/34d83c3e6e97867ae061d14eb52123404aab1cbc
- https://git.kernel.org/stable/c/91f249b01fe490fce11fbb4307952ca8cce78724
- https://git.kernel.org/stable/c/b939d1e04a90248b4cdf417b0969c270ceb992b2
- https://git.kernel.org/stable/c/fb66df20a7201e60f2b13d7f95d031b31a8831d3
- https://git.kernel.org/stable/c/91f249b01fe490fce11fbb4307952ca8cce78724
- https://git.kernel.org/stable/c/b939d1e04a90248b4cdf417b0969c270ceb992b2
- https://git.kernel.org/stable/c/fb66df20a7201e60f2b13d7f95d031b31a8831d3
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-36244 or the next vulnerability affects your stack