What’s Vulnerable › Vulnerabilities
CVE-2024-36268: Apache InLong TubeMQ Client: Remote Code Execution vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-02 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong. This issue affects Apache InLong: from 1.10.0 through 1.12.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.13.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/10251
Affected products
- Apache Software Foundation Apache InLong: from 1.10.0 before 1.13.0 — fixed in 1.13.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache InLong 1.13.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1w1yp1bg5sjvn46dszkf00tz1vfs0frc
- http://www.openwall.com/lists/oss-security/2024/08/02/5
Get alerted when CVE-2024-36268 or the next vulnerability affects your stack