What’s Vulnerable › Vulnerabilities
CVE-2024-3632: Smart Image Gallery < 1.0.19 - Update/Delete Google API Key via CSRF
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The Smart Image Gallery WordPress plugin before 1.0.19 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Affected products
- Smart Image Gallery: before 1.0.19 — fixed in 1.0.19
How to fix
Upgrade to a fixed version: Smart Image Gallery 1.0.19. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9b11682d-4705-4595-943f-0fa093d0b644/
- https://wpscan.com/vulnerability/9b11682d-4705-4595-943f-0fa093d0b644/
Get alerted when CVE-2024-3632 or the next vulnerability affects your stack