What’s Vulnerable › Vulnerabilities
CVE-2024-36416: SuiteCRM v4 API Excessive log data DOS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-10 · updated 2026-06-17
- Weakness: CWE-779
Description
SuiteCRM is an open-source Customer Relationship Management (CRM) software application. Prior to versions 7.14.4 and 8.6.1, a deprecated v4 API example with no log rotation allows denial of service by logging excessive data. Versions 7.14.4 and 8.6.1 contain a fix for this issue.
Affected products
- salesagility SuiteCRM: before 7.14.4; from 8.0.0 before 8.6.1 — fixed in 7.14.4, 8.6.1
How to fix
Upgrade to a fixed version: salesagility SuiteCRM 7.14.4, 8.6.1. Check the vendor advisory for mitigations.
References
- https://docs.suitecrm.com/admin/releases/7.14.x/
- https://github.com/kva55/CVE-2024-36416
- https://github.com/salesagility/SuiteCRM/security/advisories/GHSA-jrpp-22g3-2j77
- https://docs.suitecrm.com/admin/releases/7.14.x/
- https://github.com/kva55/CVE-2024-36416
- https://github.com/salesagility/SuiteCRM/security/advisories/GHSA-jrpp-22g3-2j77
Get alerted when CVE-2024-36416 or the next vulnerability affects your stack