What’s Vulnerable › Vulnerabilities
CVE-2024-36465: SQL injection in Zabbix API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 39.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-02 · updated 2026-06-17
- Weakness: CWE-89
Description
A low privilege (regular) Zabbix user with API access can use SQL injection vulnerability in include/classes/api/CApiService.php to execute arbitrary SQL commands via the groupBy parameter.
Affected products
- Zabbix: from 7.0.0 through 7.0.7; from 7.2.0 before 7.2.2; 7.0.8-rc1 — fixed in 7.2.2
How to fix
Upgrade to a fixed version: Zabbix 7.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-36465 or the next vulnerability affects your stack