What’s Vulnerable › Vulnerabilities
CVE-2024-36467: Authentication privilege escalation via user groups due to missing authorization checks
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-27 · updated 2026-06-17
- Weakness: CWE-285
Description
An authenticated user with API access (e.g.: user with default User role), more specifically a user with access to the user.update API endpoint is enough to be able to add themselves to any group (e.g.: Zabbix Administrators), except to groups that are disabled or having restricted GUI access.
Affected products
- Zabbix: from 5.0.0 before 5.0.43; from 6.0.0 before 6.0.33; from 6.4.0 before 6.4.18; from 7.0.0 before 7.0.2 — fixed in 5.0.43, 6.0.33, 6.4.18, 7.0.2
How to fix
Upgrade to a fixed version: Zabbix 5.0.43, 6.0.33, 6.4.18, 7.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-36467 or the next vulnerability affects your stack