What’s Vulnerable › Vulnerabilities

CVE-2024-36492: Existing local user overwritten by malicious remote

Description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to disallow the modification of local users when syncing users in shared channels. which allows a malicious remote to overwrite an existing local user.

Affected products

How to fix

Upgrade to a fixed version: Mattermost App Framework 9.5.7, 9.7.6, 9.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-36492 or the next vulnerability affects your stack