What’s Vulnerable › Vulnerabilities
CVE-2024-36522: Apache Wicket: Remote code execution via XSLT injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-74
Description
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
Affected products
- Apache Software Foundation Apache Wicket: from 8.0.0 before 8.16.0; from 9.0.0 before 9.18.0; 10.0.0-milestone1, 10.0.0-milestone2 — fixed in 8.16.0, 9.18.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Wicket 8.16.0, 9.18.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/07/12/2
- https://lists.apache.org/thread/w613qh7yors840pbx00l1pq6wkl9jzkc
- http://www.openwall.com/lists/oss-security/2024/07/12/2
- https://lists.apache.org/thread/w613qh7yors840pbx00l1pq6wkl9jzkc
Get alerted when CVE-2024-36522 or the next vulnerability affects your stack