What’s Vulnerable › Vulnerabilities
CVE-2024-36577
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-17 · updated 2026-06-17
- Weakness: CWE-79
Description
apphp js-object-resolver < 3.1.1 is vulnerable to Prototype Pollution via Module.setNestedProperty.
Affected products
- Apphp Js-Object-Resolver: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Apphp Js-Object-Resolver 3.1.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mestrtee/c90189f3d8480a5f267395ec40701373
- https://gist.github.com/mestrtee/c90189f3d8480a5f267395ec40701373
Get alerted when CVE-2024-36577 or the next vulnerability affects your stack