What’s Vulnerable › Vulnerabilities
CVE-2024-3660: Arbitrary code injection vulnerability in Keras framework < 2.13
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-94
Description
A arbitrary code injection vulnerability in TensorFlow's Keras framework (<2.13) allows attackers to execute arbitrary code with the same permissions as the application using a model that allow arbitrary code irrespective of the application.
Affected products
- keras-team/keras: before 2.13.1 — fixed in 2.13.1
How to fix
Upgrade to a fixed version: keras-team/keras 2.13.1. Check the vendor advisory for mitigations.
References
- https://kb.cert.org/vuls/id/253266
- https://www.kb.cert.org/vuls/id/253266
- https://kb.cert.org/vuls/id/253266
- https://www.kb.cert.org/vuls/id/253266
Get alerted when CVE-2024-3660 or the next vulnerability affects your stack