What’s Vulnerable › Vulnerabilities
CVE-2024-36600
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-121
Description
Buffer Overflow Vulnerability in libcdio 2.2.0 (fixed in 2.3.0) allows an attacker to execute arbitrary code via a crafted ISO 9660 image file.
Affected products
- GNU Libcdio: from 2.2.0 before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: GNU Libcdio 2.3.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2292833
- https://github.com/gashasbi/My-Reports/tree/main/CVE-2024-36600
- https://github.com/libcdio/libcdio/pull/32
- https://github.com/libcdio/libcdio/pull/46
- https://github.com/gashasbi/My-Reports/tree/main/CVE-2024-36600
Get alerted when CVE-2024-36600 or the next vulnerability affects your stack