What’s Vulnerable › Vulnerabilities
CVE-2024-36617
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-29 · updated 2026-06-17
- Weakness: CWE-190
Description
FFmpeg n6.1.1 has an integer overflow vulnerability in the FFmpeg CAF decoder.
Affected products
- FFmpeg: before 3.4.14; from 4.0 before 4.2.9; from 4.3 before 4.3.7; from 4.4 before 4.4.5; from 5.0 before 6.1.2 — fixed in 3.4.14, 4.2.9, 4.3.7, 4.4.5, 6.1.2
How to fix
Upgrade to a fixed version: FFmpeg 3.4.14, 4.2.9, 4.3.7, 4.4.5. Check the vendor advisory for mitigations.
References
- https://gist.github.com/1047524396/f20749f8addc8f86de9cfacf17ba29df
- https://github.com/FFmpeg/FFmpeg/blob/n6.1.1/libavformat/cafdec.c#L274
- https://github.com/ffmpeg/ffmpeg/commit/d973fcbcc2f944752ff10e6a76b0b2d9329937a7
Get alerted when CVE-2024-36617 or the next vulnerability affects your stack