What’s Vulnerable › Vulnerabilities
CVE-2024-36671
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-29 · updated 2026-06-17
- Weakness: CWE-190
Description
nodemcu before v3.0.0-release_20240225 was discovered to contain an integer overflow via the getnum function at /modules/struct.c.
Affected products
- Nodemcu: before 3.0.0-release_20240225 — fixed in 3.0.0-release_20240225
How to fix
Upgrade to a fixed version: Nodemcu 3.0.0-release_20240225. Check the vendor advisory for mitigations.
References
- https://github.com/nodemcu/nodemcu-firmware/commit/193fe3593eb1537667179089535cdb7457327887#diff-5c3fa597431eda03ac3339ae6bf7f05e1a50d6fc7333679ec38e21b337cb6721
- https://github.com/nodemcu/nodemcu-firmware/issues/3626
- https://github.com/nodemcu/nodemcu-firmware/pull/3633
- https://github.com/nodemcu/nodemcu-firmware/pull/3634
- https://github.com/nodemcu/nodemcu-firmware/pull/3635
Get alerted when CVE-2024-36671 or the next vulnerability affects your stack