What’s Vulnerable › Vulnerabilities
CVE-2024-3678: Blog2Social: Social Media Auto Post & Scheduler <= 7.4.2 - Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-862
Description
The Blog2Social: Social Media Auto Post & Scheduler plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 7.4.2. This makes it possible for unauthenticated attackers to view limited information from password protected posts.
Affected products
- pr-gateway Blog2Social: Social Media Auto Post & Scheduler: before 7.5.0 — fixed in 7.5.0
How to fix
Upgrade to a fixed version: pr-gateway Blog2Social: Social Media Auto Post & Scheduler 7.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3069574/blog2social/trunk/includes/Meta.php
- https://plugins.trac.wordpress.org/changeset/3074883/blog2social/trunk/includes/Meta.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2dea1bcb-14c2-4ec9-8a4d-087bac2db486?source=cve
- https://plugins.trac.wordpress.org/changeset/3069574/blog2social/trunk/includes/Meta.php
- https://plugins.trac.wordpress.org/changeset/3074883/blog2social/trunk/includes/Meta.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2dea1bcb-14c2-4ec9-8a4d-087bac2db486?source=cve
Get alerted when CVE-2024-3678 or the next vulnerability affects your stack