What’s Vulnerable › Vulnerabilities
CVE-2024-3692: Gutenverse < 1.9.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gutenverse WordPress plugin before 1.9.1 does not validate the htmlTag option in various of its block before outputting it back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- jegstudio Gutenverse – Ultimate WordPress FSE Blocks Addons & Ecosystem: before 1.9.1 — fixed in 1.9.1
How to fix
Upgrade to a fixed version: jegstudio Gutenverse – Ultimate WordPress FSE Blocks Addons & Ecosystem 1.9.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6f100f85-3a76-44be-8092-06eb8595b0c9/
- https://wpscan.com/vulnerability/6f100f85-3a76-44be-8092-06eb8595b0c9/
Get alerted when CVE-2024-3692 or the next vulnerability affects your stack