What’s Vulnerable › Vulnerabilities
CVE-2024-36920: scsi: mpi3mr: Avoid memcpy field-spanning write WARNING
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: mpi3mr: Avoid memcpy field-spanning write WARNING When the "storcli2 show" command is executed for eHBA-9600, mpi3mr driver prints this WARNING message: memcpy: detected field-spanning write (size 128) of single field "bsg_reply_buf->reply_buf" at drivers/scsi/mpi3mr/mpi3mr_app.c:1658 (size 1) WARNING: CPU: 0 PID: 12760 at drivers/scsi/mpi3mr/mpi3mr_app.c:1658 mpi3mr_bsg_request+0x6b12/0x7f10 [mpi3mr] The cause of the WARN is 128 bytes memcpy to the 1 byte size array "__u8 replay_buf[1]" in the struct mpi3mr_bsg_in_reply_buf. The array is intended to be a flexible length array, so the WARN is a false positive. To suppress the WARN, remove the constant number '1' from the array declaration and clarify that it has flexible length. Also, adjust the memory allocation size to match the change.
Affected products
- Linux kernel: from 5.14 before 6.1.91; from 6.2 before 6.6.31; from 6.7 before 6.8.10; 6.9-rc1 — fixed in 6.1.91, 6.6.31, 6.8.10
How to fix
Upgrade to a fixed version: Linux kernel 6.1.91, 6.6.31, 6.8.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/429846b4b6ce9853e0d803a2357bb2e55083adf0
- https://git.kernel.org/stable/c/4d2772324f43cf5674ac3dbe3f74a7e656396716
- https://git.kernel.org/stable/c/5f0266044dc611563539705bff0b3e1545fbb6aa
- https://git.kernel.org/stable/c/f09318244c6cafd10aca741b9c01e0a2c362d43a
- https://git.kernel.org/stable/c/429846b4b6ce9853e0d803a2357bb2e55083adf0
- https://git.kernel.org/stable/c/4d2772324f43cf5674ac3dbe3f74a7e656396716
- https://git.kernel.org/stable/c/5f0266044dc611563539705bff0b3e1545fbb6aa
- https://git.kernel.org/stable/c/f09318244c6cafd10aca741b9c01e0a2c362d43a
Get alerted when CVE-2024-36920 or the next vulnerability affects your stack