What’s Vulnerable › Vulnerabilities
CVE-2024-36921: wifi: iwlwifi: mvm: guard against invalid STA ID on removal
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: iwlwifi: mvm: guard against invalid STA ID on removal Guard against invalid station IDs in iwl_mvm_mld_rm_sta_id as that would result in out-of-bounds array accesses. This prevents issues should the driver get into a bad state during error handling.
Affected products
- Linux kernel: before 6.6.31; from 6.7 before 6.8.10; 6.9-rc1 — fixed in 6.6.31, 6.8.10
How to fix
Upgrade to a fixed version: Linux kernel 6.6.31, 6.8.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/17f64517bf5c26af56b6c3566273aad6646c3c4f
- https://git.kernel.org/stable/c/94f80a8ec15e238b78521f20f8afaed60521a294
- https://git.kernel.org/stable/c/fab21d220017daa5fd8a3d788ff25ccfecfaae2f
- https://git.kernel.org/stable/c/17f64517bf5c26af56b6c3566273aad6646c3c4f
- https://git.kernel.org/stable/c/94f80a8ec15e238b78521f20f8afaed60521a294
- https://git.kernel.org/stable/c/fab21d220017daa5fd8a3d788ff25ccfecfaae2f
Get alerted when CVE-2024-36921 or the next vulnerability affects your stack