What’s Vulnerable › Vulnerabilities
CVE-2024-36946: phonet: fix rtm_phonet_notify() skb allocation
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: phonet: fix rtm_phonet_notify() skb allocation fill_route() stores three components in the skb: - struct rtmsg - RTA_DST (u8) - RTA_OIF (u32) Therefore, rtm_phonet_notify() should use NLMSG_ALIGN(sizeof(struct rtmsg)) + nla_total_size(1) + nla_total_size(4)
Affected products
- Debian Linux: 10.0
- Linux kernel: from 2.6.33 before 4.19.314; from 4.20 before 5.4.276; from 5.5 before 5.10.217; from 5.11 before 5.15.159; from 5.16 before 6.1.91; from 6.2 before 6.6.31 — fixed in 4.19.314, 5.10.217, 5.15.159, 5.4.276, 6.1.91, 6.6.31
How to fix
Upgrade to a fixed version: Linux kernel 4.19.314, 5.10.217, 5.15.159, 5.4.276. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4ff334cade9dae50e4be387f71e94fae634aa9b4
- https://git.kernel.org/stable/c/728a83160f98ee6b60df0d890141b9b7240182fe
- https://git.kernel.org/stable/c/9a77226440008cf04ba68faf641a2d50f4998137
- https://git.kernel.org/stable/c/d8cac8568618dcb8a51af3db1103e8d4cc4aeea7
- https://git.kernel.org/stable/c/dc6beac059f0331de97155a89d84058d4a9e49c7
- https://git.kernel.org/stable/c/ec1f71c05caeba0f814df77e0f511d8b4618623a
- https://git.kernel.org/stable/c/ee9e39a6cb3ca2a3d35b4ae25547ee3526a44d00
- https://git.kernel.org/stable/c/f085e02f0a32f6dfcfabc6535c9c4a1707cef86b
- https://git.kernel.org/stable/c/4ff334cade9dae50e4be387f71e94fae634aa9b4
- https://git.kernel.org/stable/c/728a83160f98ee6b60df0d890141b9b7240182fe
- https://git.kernel.org/stable/c/9a77226440008cf04ba68faf641a2d50f4998137
- https://git.kernel.org/stable/c/d8cac8568618dcb8a51af3db1103e8d4cc4aeea7
Get alerted when CVE-2024-36946 or the next vulnerability affects your stack