What’s Vulnerable › Vulnerabilities
CVE-2024-36947: qibfs: fix dentry leak
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: qibfs: fix dentry leak simple_recursive_removal() drops the pinning references to all positives in subtree. For the cases when its argument has been kept alive by the pinning alone that's exactly the right thing to do, but here the argument comes from dcache lookup, that needs to be balanced by explicit dput(). Fucked-up-by: Al Viro <viro@zeniv.linux.org.uk>
Affected products
- Linux kernel: from 5.13 before 5.15.159; from 5.16 before 6.1.91; from 6.2 before 6.6.31; from 6.7 before 6.8.10; 6.9-rc1, 6.9-rc2, 6.9-rc3, 6.9-rc4, 6.9-rc5, 6.9-rc6 (+1) — fixed in 5.15.159, 6.1.91, 6.6.31, 6.8.10
How to fix
Upgrade to a fixed version: Linux kernel 5.15.159, 6.1.91, 6.6.31, 6.8.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/02ee394a5d899d9bd2f0759382e9481cab6166f8
- https://git.kernel.org/stable/c/24dd9b08df718f20ccf2dd1519909fefd8c233ee
- https://git.kernel.org/stable/c/aa23317d0268b309bb3f0801ddd0d61813ff5afb
- https://git.kernel.org/stable/c/bd8f78c71defbcb7a9ed331e7f287507df972b00
- https://git.kernel.org/stable/c/db71ca93259dd1078bcfea3afafde2143cfc2da7
- https://git.kernel.org/stable/c/02ee394a5d899d9bd2f0759382e9481cab6166f8
- https://git.kernel.org/stable/c/24dd9b08df718f20ccf2dd1519909fefd8c233ee
- https://git.kernel.org/stable/c/aa23317d0268b309bb3f0801ddd0d61813ff5afb
- https://git.kernel.org/stable/c/bd8f78c71defbcb7a9ed331e7f287507df972b00
- https://git.kernel.org/stable/c/db71ca93259dd1078bcfea3afafde2143cfc2da7
Get alerted when CVE-2024-36947 or the next vulnerability affects your stack