What’s Vulnerable › Vulnerabilities
CVE-2024-36958: NFSD: Fix nfsd4_encode_fattr4() crasher
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: Fix nfsd4_encode_fattr4() crasher Ensure that args.acl is initialized early. It is used in an unconditional call to kfree() on the way out of nfsd4_encode_fattr4().
Affected products
- Linux kernel: from 6.7 before 6.8.10; 6.9-rc1, 6.9-rc2, 6.9-rc3, 6.9-rc4, 6.9-rc5, 6.9-rc6 — fixed in 6.8.10
- NetApp Converged Systems Advisor Agent: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Hci Compute Node: all versions
- NetApp Solidfire & Hci Management Node: all versions
- NetApp Solidfire & Hci Storage Node: all versions
How to fix
Upgrade to a fixed version: Linux kernel 6.8.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/18180a4550d08be4eb0387fe83f02f703f92d4e7
- https://git.kernel.org/stable/c/6a7b07689af6e4e023404bf69b1230f43b2a15bc
- https://git.kernel.org/stable/c/18180a4550d08be4eb0387fe83f02f703f92d4e7
- https://git.kernel.org/stable/c/6a7b07689af6e4e023404bf69b1230f43b2a15bc
- https://security.netapp.com/advisory/ntap-20250404-0007/
Get alerted when CVE-2024-36958 or the next vulnerability affects your stack