What’s Vulnerable › Vulnerabilities

CVE-2024-36983: Command Injection using External Lookups

Description

In Splunk Enterprise versions below 9.2.2, 9.1.5, and 9.0.10 and Splunk Cloud Platform versions below 9.1.2312.109 and 9.1.2308.207, an authenticated user could create an external lookup that calls a legacy internal function. The authenticated user could use this internal function to insert code into the Splunk platform installation directory. From there, the user could execute arbitrary code on the Splunk platform Instance.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.0.10, 9.1.5, 9.2.2; Splunk Cloud Platform 9.1.2308.207, 9.1.2312.109. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-36983 or the next vulnerability affects your stack