What’s Vulnerable › Vulnerabilities

CVE-2024-36986: Risky command safeguards bypass through Search ID query in Analytics Workspace

Description

In Splunk Enterprise versions below 9.2.2, 9.1.5, and 9.0.10 and Splunk Cloud Platform versions below 9.1.2312.200 and 9.1.2308.207, an authenticated user could run risky commands using the permissions of a higher-privileged user to bypass SPL safeguards for risky commands in the Analytics Workspace. The vulnerability requires the authenticated user to phish the victim by tricking them into initiating a request within their browser. The authenticated user should not be able to exploit the vulnerability at will.

Affected products

How to fix

Upgrade to a fixed version: Splunk Cloud 9.1.2308.207, 9.1.2312.200; Splunk Enterprise 9.0.10, 9.1.5, 9.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-36986 or the next vulnerability affects your stack