What’s Vulnerable › Vulnerabilities
CVE-2024-36992: Persistent Cross-site Scripting (XSS) in Dashboard Elements
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-79
Description
In Splunk Enterprise versions below 9.2.2, 9.1.5, and 9.0.10 and Splunk Cloud Platform versions below 9.1.2312.200 and 9.1.2308.207, a low-privileged user that does not hold the admin or power Splunk roles could craft a malicious payload through a View that could result in execution of unauthorized JavaScript code in the browser of a user. The “url” parameter of the Dashboard element does not have proper input validation to reject invalid URLs, which could lead to a Persistent Cross-site Scripting (XSS) exploit.
Affected products
- Splunk Enterprise: from 9.0.0 before 9.0.10; from 9.1.0 before 9.1.5; from 9.2.0 before 9.2.2 — fixed in 9.0.10, 9.1.5, 9.2.2
- Splunk Cloud Platform: from 9.1.2308 before 9.1.2308.207; from 9.1.2312 before 9.1.2312.200 — fixed in 9.1.2308.207, 9.1.2312.200
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.0.10, 9.1.5, 9.2.2; Splunk Cloud Platform 9.1.2308.207, 9.1.2312.200. Check the vendor advisory for mitigations.
References
- https://advisory.splunk.com/advisories/SVD-2024-0712
- https://advisory.splunk.com/advisories/SVD-2024-0712
Get alerted when CVE-2024-36992 or the next vulnerability affects your stack