What’s Vulnerable › Vulnerabilities

CVE-2024-36993: Persistent Cross-site Scripting (XSS) in Web Bulletin

Description

In Splunk Enterprise versions below 9.2.2, 9.1.5, and 9.0.10 and Splunk Cloud Platform versions below 9.1.2312.200 and 9.1.2308.207, a low-privileged user that does not hold the admin or power Splunk roles could craft a malicious payload through a Splunk Web Bulletin Messages that could result in execution of unauthorized JavaScript code in the browser of a user.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.0.10, 9.1.5, 9.2.2; Splunk Cloud Platform 9.1.2308.207, 9.1.2312.200. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-36993 or the next vulnerability affects your stack