What’s Vulnerable › Vulnerabilities
CVE-2024-3703: Carousel Slider < 2.2.10 - Editor+ Stored XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Carousel Slider WordPress plugin before 2.2.10 does not validate and escape some of its Slide options before outputting them back in the page/post where the related Slide shortcode is embed, which could allow users with the Editor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Carousel Slider: before 2.2.10 — fixed in 2.2.10
How to fix
Upgrade to a fixed version: Carousel Slider 2.2.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3242b820-1da0-41ba-9f35-7be5dbc6d4b0/
- https://wpscan.com/vulnerability/3242b820-1da0-41ba-9f35-7be5dbc6d4b0/
Get alerted when CVE-2024-3703 or the next vulnerability affects your stack