What’s Vulnerable › Vulnerabilities
CVE-2024-37079: Broadcom VMware vCenter Server Out-of-bounds Write Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-01-23
- EPSS: 22.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-18 · updated 2026-06-17
- Weakness: CWE-787
Description
vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger this vulnerability by sending a specially crafted network packet potentially leading to remote code execution.
Summary
CVE-2024-37079 is a critical heap-overflow flaw in VMware vCenter Server's DCERPC protocol implementation, allowing an attacker with network access to send a crafted packet that may lead to remote code execution (CVSS 9.8). It affects VMware vCenter Server and VMware Cloud Foundation, with Cloud Foundation fixed in 5.2. The vulnerability is listed in CISA's Known Exploited Vulnerabilities catalog with active exploitation, and EPSS gives a 22.4% probability of exploitation in 30 days. Apply mitigations per vendor instructions, follow BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CVE-2024-37079 ثغرة حرجة من نوع تجاوز سعة المخزن المؤقت (heap overflow) في تنفيذ بروتوكول DCERPC في VMware vCenter Server، تتيح لجهة فاعلة خبيثة لديها وصول شبكي إلى الخادم إرسال حزمة شبكية مصممة خصيصاً قد تؤدي إلى تنفيذ تعليمات برمجية عن بُعد (CVSS 9.8). تؤثر الثغرة في VMware vCenter Server وVMware Cloud Foundation، وقد تم إصلاحها في Cloud Foundation 5.2. الثغرة مدرجة في كتالوج CISA للثغرات المعروفة المستغلة مع استغلال نشط، وتبلغ احتمالية الاستغلال خلال 30 يوماً وفق EPSS نسبة 22.4%. يجب تطبيق التخفيفات وفق تعليمات المورّد، واتباع إرشادات BOD 22-01 للخدمات السحابية، أو إيقاف استخدام المنتج إذا لم تتوفر التخفيفات.
Affected products
- VMware Cloud Foundation: from 4.0 before 5.2 — fixed in 5.2
- VMware vCenter Server: 8.0, 8.0-a, 8.0-b, 8.0-c, 8.0-update1, 8.0-update1a (+37)
- VMware Cloud Foundation: 5.x, 4.x
- VMware vCenter Server: from 8.0 before 8.0 U2d; from 8.0 before 8.0 U1e; from 7.0 before 7.0 U3r — fixed in 8.0 U2d, 8.0 U1e, 7.0 U3r
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.2; VMware vCenter Server 8.0 U2d, 8.0 U1e, 7.0 U3r. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-37079
Get alerted when CVE-2024-37079 or the next vulnerability affects your stack