What’s Vulnerable › Vulnerabilities
CVE-2024-37080
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-18 · updated 2026-06-17
- Weakness: CWE-787
Description
vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger this vulnerability by sending a specially crafted network packet potentially leading to remote code execution.
Affected products
- VMware vCenter Server: 8.0, 8.0-a, 8.0-b, 8.0-c, 8.0-update1, 8.0-update1a (+37)
- VMware Cloud Foundation: from 4.0 before 6.0 — fixed in 6.0
- VMware vCenter Server: from 8.0 before 8.0u2d; from 8.0 before 8.0u1e — fixed in 8.0u2d, 8.0u1e
- VMware Cloud Foundation: 5.x, 4.x
- VMware vCenter Server: from 8.0 before 8.0 U2d; from 8.0 before 8.0 U1e; from 7.0 before 7.0 U3r — fixed in 8.0 U2d, 8.0 U1e, 7.0 U3r
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 6.0; VMware vCenter Server 8.0u2d, 8.0u1e; VMware vCenter Server 8.0 U2d, 8.0 U1e, 7.0 U3r. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
Get alerted when CVE-2024-37080 or the next vulnerability affects your stack